Cela faisait un moment que je souhaitais mesure la consommation d’eau de mon logement, mais j’avais été freiné par le coût de mise en place d’un système de télérelève pour intégration à mon installation domotiqe. En effet, il fallait acquérir le compteur d’eau à impulsions (75€), mais aussi le RFXMeter (70€) et RFXPulse (50 €), le tout devant être branché électriquement via un adaptateur secteur. Ca faisait quand même plus de 200€ le bazar pour suivre sa consommation d’eau… (sans compter évidemment le récepteur RFXCom que j’avais déjà)

Bref tout ça m’avait refroidit.

 

C’est en lisant une discussion sur le forum TouteLaDomotique que j’ai vu un des membres (titi_oft) expliquer comment il souhaitait fait pour remplacer le couteux couple RFXMeter + RFXPulse.

Il s’agissait en fait de relier le compteur à impulsions à un simple détecteur d’ouverture Chacon désossé. En effet le détecteur d’ouverture Chacon est un détecteur magnétique qui utilise une technologie dit à ampoule REED, ce qui est également le cas de mon compteur d’eau à impulsion. C’est un peu à la ‘bricolo bricolette’, mais ça a le mérte de fonctionner et de diviser le budget par 2 ;) Voici comment procéder :

 

Le matériel :

  • Un compteur d’eau à impulsion (1 impulsion/litre) : 75€ environ (chez planete-domotique par exemple)
  • Un  capteur d’ouverture Chacon  : 15€ environ (lien chez planete-domotique)
  • Un récepteur compatible avec Chacon (RFXCom, ZiBase…)
  • Un fer à souder, de l’étain, des mains (deux devraient suffire) et un tournevis

 

Le compteur d’eau :

 

Le compteur est livré dans un carton, avec ses accessoires (adaptateurs, joints, et cable). Je ne suis pas plombier, mais le tout semble de très bonne qualité.

 

Modification du détecteur d’ouverture :

Bon ça c’est le détecteur Chacon. Vous pouvez jeter la plus petite partie, elle ne contient qu’un aimant et vous sera inutile. Il faut alors ouvrir la partie la plus grande en dévissant la vis  au dos puis en déclipsant le plastique  :

Ca vous donne à peu près ça. Vous pouvez voir l’emplacement de la pile à gauche, l’antenne à droite, et la fameuse ampoule REED en bas :

C’est aux bornes de cette ampoule reed que nous allons souder les deux fils de notre compteur à impulsion. Il ne restera ensuite plus qu’à retirer l’ampoule reed en sectionnant ses pattes, et à replacer la carte électronique dans son boitier :

 

 

Et voila ! Vous refermez le boitier, mettez la pile, et votre détecteur chacon émettra à chaque litre d’eau consommé; le tout pour moins de 100€. Elle est pas belle la vie ?

 

Le comptage du volume d’eau :

Attention il y a une subtilité. Comme vous le savez peut etre, les détecteurs chacon (comme les detecteurs X10 d’ailleurs) ont une facheuse tendance à envoyer plusieurs fois d’affilée leurs ordres, afin de s’assurer que ceux-ci sont bien reçus. Ce qui fait que, dans notre montage, si on compte simplement le nombre de « ON » envoyés, on va se retrouver avec un chiffre bien au dessus de la consommation réelle.

L’astuce consiste, au lieu de compter les « ON », à compter les changements d’état « OFF » => « ON ». En utilisant cette méthode, on obtient une très bonne précision (chez moi, le taux d’erreur est d’environ 0.3%, ce qui est plus que satisfaisant). Personnellement j’ai juste fait un petit agent xPL qui écoute les ordres du capteur et les retransmet sur le réseau xPL un fois convertis en données de volume.

 

Les limites et les inconnues :

  • Durée de vie de la pile du détecteur Chacon : je ne sais pas dire combien de temps tiendra la pile bouton du détecteur. Ces petits modules n’étant pas faits pour émettre plusieurs centaines de fois par jour. Pour le moment je suis à environ 8000L consommés et pas de problème.
  • Occupation de la fréquence : Il est possible que, lorsque l’on consomme beaucoup d’eau (ex. une bonne grosse douche, ou arrosage jardin…) le détecteur émette des ordre à un rythme élevé, ce qui pourrait ‘occuper’ la fréquence 433Mhz et provoquer des ratés sur d’autres devices (par exemple non-réception d’une trame d’une sonde Oregon ou autre…). Je n’ai pas constaté ce problème pour le moment mais c’est une éventualité.

 

Voila, c’est clairement un peu bricolo bricolette mais ça fonctionne plutôt bien jusqu’à présent après 1 mois d’utilisation :) . J’en profite pour remercier titi_oft du forum TLD pour son idée !